Quantcast AddOns won't work - Page 3 - ESOUI
Thread Tools Display Modes
07/11/16, 11:53 PM   #41
Ardawen
Join Date: Mar 2014
Posts: 9
Funny, somehow i have not installed one drive, because i didn't know what kind of program it was and i was like why should i use that, i already have a documents file and it is on a different drive, still eso or minion is not the easiest to work with as it wants to be placed in a certain place and then sometimes it messes up the addons you already had installed, specialy if you use both servers to play on.
  Reply With Quote
06/07/17, 07:00 PM   #42
JoeR
Join Date: Jun 2017
Posts: 1
Originally Posted by jgq85 View Post
Hi I just registered to sign in and post what fixed this issue for me.

Open your PC/main folder, then right-click on the "Document" folder (or library shortcut -- whatever it's called) and choose Properties.

Click the "Location" tab.
Notice the path there may be pointing elsewhere?
Mine was, due to wanting to save space from my SSD by defaulting the "Documents" folder to my bigger HDD (E-Drive).
I had to reset this location back to default, after I moved my data to another folder as to not overfill my C-Drive.

But yeah, now it works and I see my add-ons..!
Thank you, jgq85! I also moved my "Documents" library off my SSD. I made the location change with a registry modification, and then I used the Windows UI to change the library back to point at C: because... reasons. The Documents library was working properly as far as I could tell, but even though I had the files properly in BOTH locations, ESO refused to acknowledge them until I hit the "Restore Default" button.
  Reply With Quote
07/05/17, 09:52 AM   #43
jmrathbun
Join Date: Aug 2014
Posts: 3
Addendum

It's helpful to note that it is the LAUNCHER, not the server log-in, that inspects your add-ons folder. So when playing around with add-ons to make one show up as loaded, it isn't enough to log off and log back on. You have to close the launcher and then re-launch it.

I also ran afoul of an unzipping protocol that stuck an extra folder into the works and screwed things up. My correct install path was C:\Users\JMR\Documents\Elder Scrolls Online\live\AddOns\RaidNotifier\(folders & files) or C:\Users\JMR\Documents\Elder Scrolls Online\live\AddOns\RaidNotifier-2.0.0\(folders & files) but NOT C:\Users\JMR\Documents\Elder Scrolls Online\live\AddOns\RaidNotifier-2.0.0\RaidNotifier\(folders & files).

I hope this helps!
  Reply With Quote
07/05/17, 10:29 AM   #44
sirinsidiator
 
sirinsidiator's Avatar
AddOn Author - Click to view addons
Join Date: Apr 2014
Posts: 1,127
Originally Posted by jmrathbun View Post
It's helpful to note that it is the LAUNCHER, not the server log-in, that inspects your add-ons folder. So when playing around with add-ons to make one show up as loaded, it isn't enough to log off and log back on. You have to close the launcher and then re-launch it.
The launcher doesn't have anything to do with the addons. You can install new addons and type /reloadui in chat and they will show up.
__________________
>siri.exe MyAddon
Does your addon work? [y/n] n
There is a typo in there.
  Reply With Quote
07/05/17, 12:08 PM   #45
silvereyes
 
silvereyes's Avatar
AddOn Author - Click to view addons
Join Date: Aug 2015
Posts: 51
Originally Posted by jmrathbun View Post
So when playing around with add-ons to make one show up as loaded, it isn't enough to log off and log back on. You have to close the launcher and then re-launch it.
This isn't really entirely true. As sirinsidiator noted, doing a /reloadui in-game is sufficient to get the addon to appear.

You are correct that if you are on the character selection screen when you install your addon, simply signing out of your account and logging back in will not make the addon appear under the Addons list on the character selection screen. But you don't need to close/reopen the launcher. Just closing ESO and re-launching the game will make the addon appear in the character selection screen.
  Reply With Quote
10/07/17, 03:34 PM   #46
KajiraJess
Join Date: Sep 2017
Posts: 3
C:\Users\jmfug\Documents\Elder Scrolls Online\live\AddOns

next level:
C:\Users\jmfug\Documents\Elder Scrolls Online\live\AddOns\wykkyd_core_libraries\LAM\controls

My Addons will not come up in the game, I have tried everything in this thread and more.... I have uninstalled the game, minion and other addon managers and tried reinstalling them. Nothing is working and it is getting frustrating. I am playing with a group and they have tried to fix it as well. This is a brand new computer so there should not be anything on my system holding it up... nothing I try works getting
  Reply With Quote
10/07/17, 03:36 PM   #47
Ayantir
 
Ayantir's Avatar
AddOn Author - Click to view addons
Join Date: Jul 2014
Posts: 1,022
http://wiki.esoui.com/UserFolder

Note: On some Windows 10 machines it may be located in %userprofile%\OneDrive\Documents\Elder Scrolls Online\ if One Drive is active.
Note: On some computers, the folder can be elsewhere on the computer. A search of file UserSettings.txt is able to help you in order to find the correct path.
__________________
Obsessive Compulsive Coder

My little french Guild: Cercle de l'Eveil
  Reply With Quote
10/07/17, 03:46 PM   #48
KajiraJess
Join Date: Sep 2017
Posts: 3
Originally Posted by Garkin View Post
Each addon has to be inside of its own folder.
Download the latest Wykkyd's Framework (mhFramework.zip file), double click on it to see what is inside and drag&drop whole "mhFramework" folder to Documents\Elder Scrolls Online\live\AddOns\.
C:\Users\jmfug\Documents\Elder Scrolls Online\live\AddOns

next level:
C:\Users\jmfug\Documents\Elder Scrolls Online\live\AddOns\wykkyd_core_libraries\LAM\controls

My Addons will not come up in the game, I have tried everything in this thread and more.... I have uninstalled the game, minion and other addon managers and tried reinstalling them. Nothing is working and it is getting frustrating. I am playing with a group and they have tried to fix it as well. This is a brand new computer so there should not be anything on my system holding it up... nothing I try works getting
  Reply With Quote
10/07/17, 04:34 PM   #49
Ayantir
 
Ayantir's Avatar
AddOn Author - Click to view addons
Join Date: Jul 2014
Posts: 1,022
__________________
Obsessive Compulsive Coder

My little french Guild: Cercle de l'Eveil
  Reply With Quote
10/07/17, 05:32 PM   #50
KajiraJess
Join Date: Sep 2017
Posts: 3
Originally Posted by Ayantir View Post
Thank you so much, that was it.
  Reply With Quote
10/12/17, 06:08 PM   #51
kray1222
Join Date: Oct 2017
Posts: 1
Talking I Made An Account To Say This Worked For Me!

Originally Posted by jgq85 View Post
Hi I just registered to sign in and post what fixed this issue for me.

Open your PC/main folder, then right-click on the "Document" folder (or library shortcut -- whatever it's called) and choose Properties.

Click the "Location" tab.
Notice the path there may be pointing elsewhere?
Mine was, due to wanting to save space from my SSD by defaulting the "Documents" folder to my bigger HDD (E-Drive).
I had to reset this location back to default, after I moved my data to another folder as to not overfill my C-Drive.

But yeah, now it works and I see my add-ons..!
After all the stress and back/forth in my folders, THIS^^^RIGHT^^^HERE^^^DID^^^IT!
  Reply With Quote
01/03/18, 09:09 PM   #52
naahkala
Join Date: Jan 2018
Posts: 1


C:\ProgramData\Elder Scrolls Online\live
  Reply With Quote
01/04/18, 10:53 AM   #53
Baertram
 
Baertram's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2014
Posts: 1,769
C:\ProgramData looks wrong. Try to copy the contents of c:\ProgramData\"Elder Scrolls Online" to "C:\Users\<your windows username>\Documents\Elder Scrolls Online" or wherever your userfolder of windows is located
  Reply With Quote
01/05/18, 08:41 AM   #54
bobtilla
Join Date: Jan 2018
Posts: 1
Is it worth the trouble?

New to ESO and to minion. I read this was fixed back in 2014, yet I see so many people having same problem as I am. See it in local, back up folder in documents, but not in game. Everyone I see saying they found their fix, each were different. As for my computer savviness, I know enough to be dangerous.
  Reply With Quote
01/05/18, 11:20 AM   #55
Baertram
 
Baertram's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2014
Posts: 1,769
Hey bobtilla, from your post I cannot be sure where your addons are located on your harddrive now.
Where exactly (folder path) are they lcoated?

They should be somewhere in c:\users\<your windows username>\documents\Elder Scrolls Online\AddOns\".
Check this link:
http://wiki.esoui.com/UserFolder

Be sure to check the screenshots of Ayantir abvove and read + understand how Microsoft OneDrive is working and how it interfers with the ESO addons (forum search: onedrive)
  Reply With Quote
03/03/18, 01:59 PM   #56
Armyvet643
Join Date: Mar 2018
Posts: 2
I have checked over and over again to make sure that my add ons were in the correct file path, I have even checked to make sure that the add ons have actual data, I have even verified with minion that the add ons are installed.

ESO will not recognize that I have add ons. Up to date or our of date. I have the box checked to allow out of date add ons.

I don't know what else to do? I only had this problem after being forced to switch to win 10 because of a hard drive crash

This PC > Local Disk (C: ) > Users > armyv > Documents > Elder Scrolls Online > Live > AddOns
  Reply With Quote
03/03/18, 02:11 PM   #57
Armyvet643
Join Date: Mar 2018
Posts: 2
Seems I managed to get it to work, but not with the mentioned path.

Instead, my path looks like this.

This PC > Documents > Elder Scrolls Online > Live > AddOns

Not sure if this is an issue with Win 10, but hopefully it helps others.
  Reply With Quote
03/03/18, 03:32 PM   #58
Baertram
 
Baertram's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2014
Posts: 1,769
You are using Microsoft OneDrive then most probably and this is the problem. Check the forum for win10 and one drive, there are enough threads.
This comes in my mind as you said it's not c: drive + users/documents but my computer/documents. This is a link to the actual documents folder. If you click the address line you'll see the actual directory and I bet it's something with OneDrive then?
  Reply With Quote
07/25/18, 10:50 AM   #59
Dueydoodah
Join Date: Aug 2015
Posts: 6
This is an old thread but I have new information so it seems the best place to post.

Addons will not show up at all if you enable Windows Defender->App & Browser Control->Ransomeware Protection->Controlled Folder Access.

I'm not sure if this is an oversight by Microsoft or ZOS or if it's just how this type of protection is required to work (my suspicion is it is working as intended) but in any case, it would be nice if the power that be find a work around.
  Reply With Quote

ESOUI » AddOns » AddOn Help/Support » AddOns won't work

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off