ZAM's Minion, currently in open beta, is a new AddOn manager optimized for use with ESO. Install, update & manage AddOns... Learn more!
Download
(132 Kb)
Download
Updated: 06/26/14 09:41 PM
Pictures
File Info
Compatibility:
Veteran Crypt of Hearts (1.2.3)
Updated:06/26/14 09:41 PM
Created:03/16/14 12:09 AM
Downloads:229,808
Favorites:554
MD5:
1.2.3
Inventory Grid View  Popular! (More than 5000 hits)
Version: 1.1.5
by: ingeniousclown, Randactyl
Hey! As of update 1.1.3, it is now possible to easily create your own skins for others to download! Please see the Inventory Grid View Skin Template for more details!


Replace your default inventory's list view with a more compact grid view! The default list view shows 11-12 items at a time (in my case), so it can become a pain to navigate your inventory.

Grid view sacrifices detailed information for more pictures. Sometimes you want the detailed information, so I've included a button at the bottom that will toggle the grid on and off.

Features:
  • Grid view for your main inventory, your bank, AND your guild bank!
  • Toggle grid view on and off! Useful for when you need to scan with more information.
  • Don't like the outlines? Turn them off!
  • Customizable grid size.
  • Two different skins to choose from!
  • Works with Research Assistant and Advanced Filters!

Special thanks to Rushmik for supplying the art for his skin!



If you like what I'm doing, why not consider donating? Remember that this is IN NO WAY REQUIRED to enjoy my add-ons! Just think of it as an extra way to say "Hey man, I like what you're doing. Can I buy you a beer?"

v1.1.5
-Update to LibAddonMenu-2.0r8
-Updated to API 100007 and added requisite README


v1.1.4
-Updated to LibAddonMenu-2.0r7
-The example grid box in the settings menu will now react again to mouseovers and outline toggling.


v1.1.3b
-Updated to LibAddonMenu-2.0r6 - this will put the dropdown menus back in the correct order.


v1.1.3
-Updated to LibAddonMenu-2.0
-Updating LibAddonMenu-2.0 broke part of the functionality of the "example" in the settings. The basic part of it still works, and that's all that's really necessary.
-Added "Circles: by Tonyleila"
-I'm tired of adding skins, so I wrote a function to register them with an external add-on. Please see the template for more details.


v1.1.2
-Added skin support for the toggle icon
-Added Tonyleila's "Clean Icons" skin (with minor modifications)
-Icons from other addons that rely on the row's "isGrid" property should now behave properly; this includes Research Assistant.
-The sample icon in the settings menu now properly reflects what skin you choose.


v1.1.1
-Update to API 100004
-Fixed a bug where AddGold would throw an error. This won't completely fix the error that everyone is talking about, because the bug is in ZO's code.
-Gold should no longer randomly stop being hidden in grid view.
-Hopefully fixed an issue with Research Assistant's icons sometimes being shifted to the right.
-Updated to the most recent revision of LAM.


v1.1.0b
-Fixed a compatibility issue with Research Assistant. This version or later is required for Research Assistant to integrate properly with the grid.


v1.1.0
-Added Rushmik's skin to the add-on.
-Added setting for skin choice in the settings menu.
-Added toggle for gold on the tooltip in the settings menu.
-Reset settings. Defaults are now to the Rushmik skin with minimum magic quality to "Magic".


v1.0.2b
-Added nil check to AddGold function
-Attempted to fix a problem where some users would see the sell value control in Grid View.


v1.0.2
-Tooltips will now add a line with the value of the stack.
-Added a "minimum quality" option for the outlines.


v1.0.1
-Fixed the bug that ruined list view when changing grid view settings for inventories that have it disabled.
-Moved the toggle button back to its home in the bottom of the window.


v1.0.0
-Settings window added under SETTINGS menu!
-Added a real icon to toggle grid view and moved it to the upper left-hand corner of the inventory window.
-Added a custom mouse-over background for the grid view that is colored by the rarity of the item. This is still colored when the outline is turned off.
-Removed the slash commands. Now you can use the SETTINGS menu.
-Added a slider to customize the size of the icons in the grid.
-Fixed a bug where the grid wasn't properly calculating the spacing between grid icons. The grid should now fill the window.


v0.4.3
-Fixed a typo that made the guild bank not work.


v0.4.2
-Fixed an issue where I was indexing the bags with the wrong global constant. As a result, the guild bank should now be grid view-able and the scrolling should now work correctly in the bank.


v0.4.1
-Fixed the scroll bar size


v0.4
-Fixed another issue with slots not reverting to list view
-Added compatibility for my new mod, Research Assistant


v0.3
-Integrated the grid view to the player bank and guild bank.
-Fixed issue where some slots wouldn't convert back to list view
-Cleaned up the code just a little bit :)


v0.21
-Updated API version so it won't say "out of date" anymore


v0.2
-Added rarity outline colors to the grid view (I hope)
-Added slash command "/inventorygridview outlines" to toggle outlines
-Added saved vars to keep track of your grid view and outline settings
-Removed the changelog from the zip because it was being read as another add-on (lol)


v0.12
-Fixed filter swapping.


v0.11
-Added a parent folder to the zip


v0.1
-Initial release
Optional Files (1)
File Name
Version
Size
Author
Date
Type
1.0
60kB
06/13/14 11:19 PM
Addon


Archived Files (21)
File Name
Version
Size
Author
Date
1.1.4
132kB
ingeniousclown
06/16/14 08:34 PM
1.1.3b
132kB
ingeniousclown
06/14/14 10:25 AM
1.1.3
132kB
ingeniousclown
06/13/14 10:51 PM
1.1.2
94kB
ingeniousclown
06/01/14 12:13 AM
1.1.1
89kB
ingeniousclown
05/25/14 10:50 AM
1.1.0b
88kB
ingeniousclown
04/28/14 11:24 PM
1.1.0
88kB
ingeniousclown
04/25/14 07:08 PM
1.0.2b
59kB
ingeniousclown
04/20/14 09:38 AM
1.0.2
59kB
ingeniousclown
04/20/14 01:42 AM
1.0.1
58kB
ingeniousclown
04/12/14 09:24 AM
1.0.0
64kB
ingeniousclown
04/11/14 11:43 PM
0.4.3
10kB
ingeniousclown
04/09/14 10:08 PM
0.4.2
10kB
ingeniousclown
04/09/14 05:18 PM
0.4.1
10kB
ingeniousclown
04/08/14 11:49 PM
0.4
10kB
ingeniousclown
04/03/14 01:00 AM
0.3
10kB
ingeniousclown
04/01/14 06:56 PM
0.21
11kB
ingeniousclown
03/30/14 01:34 PM
0.2
11kB
ingeniousclown
03/30/14 12:55 PM
0.12
5kB
ingeniousclown
03/16/14 03:11 PM
0.11
5kB
ingeniousclown
03/16/14 01:15 AM
0.1
4kB
ingeniousclown
03/16/14 12:09 AM


Post A Reply Comment Options
Old 07/01/14, 10:56 PM  
ingeniousclown
AddOn Author - Click to view AddOns

Forum posts: 124
File comments: 252
Uploads: 8
Originally Posted by GrizzlyUK
Figured I'd mention this as an FYI, it's not a complaint or anything other than a plain and simple FYI so I hope that's how it's taken.

I notice that there's a "Thumbs.db" file in the "..\InventoryGridView\assets" folder. While I'm fairly certain it's not going to cause any harm if left it might be worth removing if only to reduce folder clutter and compression file size.
That's annoying... I have my view set to show hidden files and folders but I can't see it in my own Inventory Grid View folder, only in the zip.

Bah. Thanks for the heads up.
ingeniousclown is offline Report comment to moderator  
Reply With Quote
Old 06/28/14, 06:47 PM  
ingeniousclown
AddOn Author - Click to view AddOns

Forum posts: 124
File comments: 252
Uploads: 8
Re: No entry in the settings menu!

Originally Posted by LurchUSA
G'day.

Unfortunately with the new version of ESO, I don't see the add-on entry in the settings bar, so I can resize the icon squares.

Can you please check on your mod and confirm that it is working with the latest version of ESO.
It works fine. LAM2 changes the where the settings is. Go to Settings -> AddOns
ingeniousclown is offline Report comment to moderator  
Reply With Quote
Old 06/28/14, 09:55 AM  
LurchUSA

Forum posts: 0
File comments: 3
Uploads: 0
No entry in the settings menu!

G'day.

Unfortunately with the new version of ESO, I don't see the add-on entry in the settings bar, so I can resize the icon squares.

Can you please check on your mod and confirm that it is working with the latest version of ESO.
LurchUSA is offline Report comment to moderator  
Reply With Quote
Old 06/27/14, 01:02 PM  
GrizzlyUK
 
GrizzlyUK's Avatar

Forum posts: 1
File comments: 1
Uploads: 0
Figured I'd mention this as an FYI, it's not a complaint or anything other than a plain and simple FYI so I hope that's how it's taken.

I notice that there's a "Thumbs.db" file in the "..\InventoryGridView\assets" folder. While I'm fairly certain it's not going to cause any harm if left it might be worth removing if only to reduce folder clutter and compression file size.
GrizzlyUK is offline Report comment to moderator  
Reply With Quote
Old 06/26/14, 11:29 PM  
Tonyleila
 
Tonyleila's Avatar
AddOn Author - Click to view AddOns

Forum posts: 182
File comments: 319
Uploads: 6
Re: Re: Empty Icons

Thanks for the update!

Originally Posted by ingeniousclown
....damnit. I'm running out of ideas for this issue.
Maybe I noticed something important about this issue.
When I move many items to the bank by just pressing "E" e.g. many enchanting materials it sometimes happens that suddenly the rows mess up and I get a very different item under the mouse as it was before. Its like it auto sorted the items by a new order when I remove some items from my bags. This is maybe the moment when it happens in bags
I have to test this again maybe I can find out more...

edit: At the bank the problem is different. Alts have a different layout at the bank items are sown in an other sorted way, Now they I log on an other char where I have an other sorting the research incons stay right there where they were at the last time I checked the bank

Edit 2: tested this:

Test 1 Left to right:
1. Starting with Value sorted bank on main 2. Go to alts bank view that is sorted different: icons are NOT messed up! 3. Going back to my Main: Sorting has changed and icons are messed up!



Test 2 Left to right:
1. Starting with sorted by name on my main 2. go to alt and see the bank icons are messed up 3. So I talk to the bank guy again to get it updated 4. Go back to my main: icons messed up again, untill I talk to the bank lady again :/
__________________
My Addons @ WoWInterface
Last edited by Tonyleila : 06/27/14 at 12:15 AM.
Tonyleila is offline Report comment to moderator  
Reply With Quote
Old 06/04/14, 08:19 AM  
ingeniousclown
AddOn Author - Click to view AddOns

Forum posts: 124
File comments: 252
Uploads: 8
Re: Empty Icons

Originally Posted by Tonyleila
Hey ingeniousclown, can you maybe add an option to display empty inventory space as Empty Icon borders?
This was suggested a while back, but it isn't really possible without an inordinate amount of effort on my end because of the way I accomplish the grid view. That much effort for such a small feature isn't quite worth it for me.

Code:
-Icons from other addons that rely on the row's "isGrid" property should now behave properly; this includes Research Assistant.
I realy feel this is now happening less often and the icons don't go into the next row or something but they still sometimes get offset: http://i.imgur.com/48y22Kk.jpg
....damnit. I'm running out of ideas for this issue.
ingeniousclown is offline Report comment to moderator  
Reply With Quote
Old 06/04/14, 04:42 AM  
atomico

Forum posts: 5
File comments: 28
Uploads: 0
Originally Posted by Tonyleila
Multi selling items with ins:JunkYard and moving items to the bank with Bank Manager while IVG enabled can cause disconnects and lag. The Vendor window or bank window needs longer to open and if it needs too long I get disconnected.
up
atomico is offline Report comment to moderator  
Reply With Quote
Old 06/03/14, 05:46 PM  
Tonyleila
 
Tonyleila's Avatar
AddOn Author - Click to view AddOns

Forum posts: 182
File comments: 319
Uploads: 6
Empty Icons

Hey ingeniousclown, can you maybe add an option to display empty inventory space as Empty Icon borders?

Code:
-Icons from other addons that rely on the row's "isGrid" property should now behave properly; this includes Research Assistant.
I realy feel this is now happening less often and the icons don't go into the next row or something but they still sometimes get offset: http://i.imgur.com/48y22Kk.jpg
__________________
My Addons @ WoWInterface
Last edited by Tonyleila : 06/03/14 at 08:29 PM.
Tonyleila is offline Report comment to moderator  
Reply With Quote
Old 06/03/14, 04:12 PM  
inebriant

Forum posts: 0
File comments: 1
Uploads: 0
Filter Request

Great addon!

Is it possible to add a filter for your personal inventory based on whether you also have it in the bank (and maybe vice-versa)? Pardon me if it's already there, but I didn't see it.
inebriant is offline Report comment to moderator  
Reply With Quote
Old 06/01/14, 01:38 PM  
Thaladar

Forum posts: 0
File comments: 35
Uploads: 0
Re: Re: Error

Originally Posted by ingeniousclown
I can tell by the top-most message of that window that you are running a slightly older version of Research Assistant.

You should update, as the previous version had a bug that caused that error to appear. Update RA and let me know if this error still happens.
Looks like that was it. I updated and don't see the error message. Sorry about that. Thought I was at the latest version, but clearly not.
Thaladar is offline Report comment to moderator  
Reply With Quote
Old 06/01/14, 12:11 PM  
ingeniousclown
AddOn Author - Click to view AddOns

Forum posts: 124
File comments: 252
Uploads: 8
Re: Error

Originally Posted by Thaladar
Ran into an error today when I picked up a quest reward today. I think the item is throwing off either Research Assistant or Inventory Grid View. But when I view the "All" in my inventory, this is the only item shown. And I get this error. The quest item was the Noellaume Family Heirloom.


And each time I reopen my inventory, I get this error again and the item appears twice.
I can tell by the top-most message of that window that you are running a slightly older version of Research Assistant.

You should update, as the previous version had a bug that caused that error to appear. Update RA and let me know if this error still happens.
ingeniousclown is offline Report comment to moderator  
Reply With Quote
Old 06/01/14, 10:01 AM  
Thaladar

Forum posts: 0
File comments: 35
Uploads: 0
Error

Ran into an error today when I picked up a quest reward today. I think the item is throwing off either Research Assistant or Inventory Grid View. But when I view the "All" in my inventory, this is the only item shown. And I get this error. The quest item was the Noellaume Family Heirloom.


And each time I reopen my inventory, I get this error again and the item appears twice.
Thaladar is offline Report comment to moderator  
Reply With Quote
Old 05/25/14, 11:38 AM  
Tonyleila
 
Tonyleila's Avatar
AddOn Author - Click to view AddOns

Forum posts: 182
File comments: 319
Uploads: 6
Multi selling items with ins:JunkYard and moving items to the bank with Bank Manager while IVG enabled can cause disconnects and lag. The Vendor window or bank window needs longer to open and if it needs too long I get disconnected.
__________________
My Addons @ WoWInterface
Last edited by Tonyleila : 05/25/14 at 11:39 AM.
Tonyleila is offline Report comment to moderator  
Reply With Quote
Old 05/22/14, 09:20 PM  
ingeniousclown
AddOn Author - Click to view AddOns

Forum posts: 124
File comments: 252
Uploads: 8
Originally Posted by Blackout STi
Originally Posted by Garkin
Originally Posted by Shrike
I've been getting the error everyone else has been reporting. It seems to occur after I pick up a loot item (weapon, armor, jewelry, etc) from kills, but not barrels, chests, or gathering. When it occurs, I open my inventory, click an item that is stacked, toggle grid view, and then test swapping weapons. That usually fixes it until the next item drop.
Just a quick question - I have the same issue with weapon swap even if this addon is disabled. Right now I'm trying to find out which addon causes this issue. I suspect InventoryInsight, but I do not have it confirmed yet. Do you use Vicster's InventoryInsight?

BTW in my case this slash command solves the issue:
Code:
/script ComparativeTooltip1:SetHidden(true)
What exactly does that slash command do? Just in case it doesn't resolve someone's issue, want to make sure I can reverse it (obviously just use the same command with 'false' instead). Still would like to know what it hides...

And is it the consensus that it IS this add-on that is causing the error, or is it Vicster's? I have the Inventory Insight add-on like many of you...
Just a quick tip: anything you do with /script will be reversible with a quick /reloadui

All that does is set the "IsHidden" attribute for the control named ComparativeTooltip1 to true. My guess is that at some point it isn't truly "hidden" after using it at some point, because it started out as hidden on a fresh load...

Also, I don't think it is either IGV or Vicster's II that is causing the problem. I am convinced that it is ZO's fault. (But an AddGold stack IS my fault for the most part... but as I said early, me fixing that won't completely fix the error)
ingeniousclown is offline Report comment to moderator  
Reply With Quote
Old 05/22/14, 08:29 PM  
Blackout STi

Forum posts: 3
File comments: 9
Uploads: 0
Originally Posted by Garkin
Originally Posted by Shrike
I've been getting the error everyone else has been reporting. It seems to occur after I pick up a loot item (weapon, armor, jewelry, etc) from kills, but not barrels, chests, or gathering. When it occurs, I open my inventory, click an item that is stacked, toggle grid view, and then test swapping weapons. That usually fixes it until the next item drop.
Just a quick question - I have the same issue with weapon swap even if this addon is disabled. Right now I'm trying to find out which addon causes this issue. I suspect InventoryInsight, but I do not have it confirmed yet. Do you use Vicster's InventoryInsight?

BTW in my case this slash command solves the issue:
Code:
/script ComparativeTooltip1:SetHidden(true)
What exactly does that slash command do? Just in case it doesn't resolve someone's issue, want to make sure I can reverse it (obviously just use the same command with 'false' instead). Still would like to know what it hides...

And is it the consensus that it IS this add-on that is causing the error, or is it Vicster's? I have the Inventory Insight add-on like many of you...
Blackout STi is offline Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump:

Support AddOn Development!

You have just downloaded by the author . If you like this AddOn why not consider supporting the author? This author has set up a donation account. Donations ensure that authors can continue to develop useful tools for everyone.