Quantcast
Download
(6 Kb)
Download
Updated: 05/25/19 10:56 AM
Pictures
File Info
Compatibility:
Elsweyr (5.0.5)
Updated:05/25/19 10:56 AM
Created:04/26/18 11:12 AM
Monthly downloads:751
Total downloads:3,795
Favorites:19
MD5:
5.0.5
RandomMount
Version: 2.0
by: Weolo [More]
A little addon I knocked up for nyalahalo
Essentially it summons a random mount and pet

Ther latest version of addon library LibAddonMenu is required and will need to be installed separately

Toggle between character or account settings
You can turn random pets and mounts on or off when you like
You can choose if a mount can be randomised when in pvp
Randomise pets and mounts on area change (optional)
Randomise pets and mounts on dismounting (optional)

Anyone else is welcome to use it if you like it.
2.0
- As mounts can be converted into other mounts, the list of unlocked mounts now reinitialises on character load
- List of mounts also reinitialises when you lose a mount
- The unlocked pet list functionality was unchanged
- Some other small improvements

1.9
- Updated settings to match changes in LibAddonMenu 2.0 r28
- LibStub library is no longer required

1.8.1
- Improved German translation, thanks Jaensn
- Fixed a small typo

1.8
- Ready for Elsweyr Chapter / Update 22
- Improvements to mount and pet detection
- Added new option - Toggle between character or account settings
- Added new option - You can turn random pets and mounts on or off when you like
- Added new option - You can choose if a mount can be randomised when in pvp
- Added new option - Randomise pets and mounts on area change
- Added new option - Randomise pets and mounts on dismounting
- LibStub and LibAddonMenu addon libraries are required and will need to be installed separately
- You WILL need at least version r27 of LibAddonMenu

1.7
- Updated to Wrathstone DLC / Update 21
- Updated LibStub to version 1.0 r5
- AddOnVersion tag added
- Mounts and pets won't change if you are in combat
- Changed to per character settings. Existing settings will copy to characters when logged in.

1.6
- Updated to Murkmire DLC / Update 20

1.5
- Updated to Wolfhunter DLC / Update 19
- Small improvement to detecting if you are in a pvp, added battleground check

1.4
- Updated LibAddonMenu to version 2.0 r26
- Translated to French, German, Russian and Japanese

1.3
- Mounts and pets will now not change if you are in pvp or a pvp zone
- Addon is Summerset ready

1.2
- If you have an assistant out it will now not switch to a random pet and dismiss the assistant

1.1
- Fix to not cause the "This collectable is not ready" message

1.0
- Initial release
Archived Files (11)
File Name
Version
Size
Uploader
Date
1.9
6kB
Weolo
05/02/19 11:54 AM
1.8.1
6kB
Weolo
04/26/19 02:11 PM
1.8
6kB
Weolo
04/21/19 02:40 PM
1.7
47kB
Weolo
02/28/19 02:09 PM
1.6
47kB
Weolo
10/23/18 02:02 PM
1.5
47kB
Weolo
08/14/18 01:40 PM
1.4
47kB
Weolo
05/21/18 11:09 AM
1.3
45kB
Weolo
05/15/18 12:47 PM
1.2
45kB
Weolo
05/05/18 09:38 AM
1.1
45kB
Weolo
04/28/18 01:11 AM
1.0
45kB
Weolo
04/26/18 11:12 AM


Post A Reply Comment Options
Unread Yesterday, 11:40 AM  
Pinion

Forum posts: 25
File comments: 29
Uploads: 0
Originally Posted by Weolo
Originally Posted by Pinion
Is it be possible to choose or specify a default group of mounts that I'd like to use? Say I want to only randomize camels or bears but nothing else.
Erm, interesting idea, let me think it over about if or how I could do that
Thank you for your time, whether or not it can be done.
Report comment to moderator  
Reply With Quote
Unread 06/14/19, 11:04 AM  
Weolo
AddOn Author - Click to view AddOns

Forum posts: 78
File comments: 430
Uploads: 4
Originally Posted by Pinion
Is it be possible to choose or specify a default group of mounts that I'd like to use? Say I want to only randomize camels or bears but nothing else.
Erm, interesting idea, let me think it over about if or how I could do that
Report comment to moderator  
Reply With Quote
Unread 06/13/19, 10:20 PM  
Pinion

Forum posts: 25
File comments: 29
Uploads: 0
Is it be possible to choose or specify a default group of mounts that I'd like to use? Say I want to only randomize camels or bears but nothing else.
Report comment to moderator  
Reply With Quote
Unread 05/25/19, 05:20 PM  
Sylow

Forum posts: 0
File comments: 2
Uploads: 0
Works! Thanks a lot!
Report comment to moderator  
Reply With Quote
Unread 05/25/19, 03:24 PM  
Jaensn

Forum posts: 0
File comments: 11
Uploads: 0
Thank you very much for the continuous good work you do in this!
Report comment to moderator  
Reply With Quote
Unread 05/25/19, 10:58 AM  
Weolo
AddOn Author - Click to view AddOns

Forum posts: 78
File comments: 430
Uploads: 4
Version 2.0

I just uploaded a new version, it will be available to download shortly.

This should correct the problem where you can lose a mount and then gain a new one. From events etc.
As far as I know, it is not possible to lose a pet so that is unchanged.
Report comment to moderator  
Reply With Quote
Unread 05/24/19, 09:47 AM  
Weolo
AddOn Author - Click to view AddOns

Forum posts: 78
File comments: 430
Uploads: 4
Originally Posted by LaRIC
The problem stated under fails for me on both my new necro and some other older toons. (my sorc for instance)
I am working on a fix at the moment.
I have already tried out a small improvement but I want to make one more change before I publish it.
I will try to release a fix today if I can
Report comment to moderator  
Reply With Quote
Unread 05/24/19, 01:19 AM  
LaRIC
Premium Member
Premium Member

Forum posts: 13
File comments: 9
Uploads: 0
The problem stated under fails for me on both my new necro and some other older toons. (my sorc for instance)
Report comment to moderator  
Reply With Quote
Unread 05/23/19, 05:22 AM  
Golconda

Forum posts: 0
File comments: 42
Uploads: 0
Just verifying that this also only happened for me on my new necromancer and not on any other characters.

Originally Posted by Weolo
Originally Posted by Sylow
I currently have a very strange thing. I have several characters but ONLY on my newly created character (Necromancer) this happens. When i try to edit among which mounts the addon should randomzie, i get the message "[LAM2] Cound not creatae checkbox 'Nascent Indrik' of RandomMountOptions."

On the indrik: i had the one mentioned, but i during the last event eveolved it to the luminous version. Also, for this character mounts are not being randomzied. First simply nothing happens. After zoning, i keep getting this error message:

user:/AddOns/RandomMount/RandomMount.lua:260: attempt to index a nil value
stack traceback:
user:/AddOns/RandomMount/RandomMount.lua:260: in function 'RM_Object:GetUseableMounts'
user:/AddOns/RandomMount/RandomMount.lua:273: in function 'RM_Object:SummonMount'
user:/AddOns/RandomMount/RandomMount.lua:198: in function 'func'
EsoUI/Libraries/Globals/globalapi.lua:207: in function '(anonymous)'

What is really irritating me is that it's only happening on the newly created necromancer. I don't use account wide settings, but i think the settings are the same, only different mounts selected per character.
Thanks for the info Sylow

Yeah, I never expected mounts to go away once they were learned. I will have to alter a little logic in RandomMount to be able to both add new mounts and remove ones.
Report comment to moderator  
Reply With Quote
Unread 05/22/19, 06:01 AM  
Golconda

Forum posts: 0
File comments: 42
Uploads: 0
Thanks! I tried that and then it didn't seem to work then strangely I entered a building and came back out and it seems to be working now just fine.

Originally Posted by Weolo
Originally Posted by Sylow
I currently have a very strange thing. I have several characters but ONLY on my newly created character (Necromancer) this happens. When i try to edit among which mounts the addon should randomzie, i get the message "[LAM2] Cound not creatae checkbox 'Nascent Indrik' of RandomMountOptions."

On the indrik: i had the one mentioned, but i during the last event eveolved it to the luminous version. Also, for this character mounts are not being randomzied. First simply nothing happens. After zoning, i keep getting this error message:

user:/AddOns/RandomMount/RandomMount.lua:260: attempt to index a nil value
stack traceback:
user:/AddOns/RandomMount/RandomMount.lua:260: in function 'RM_Object:GetUseableMounts'
user:/AddOns/RandomMount/RandomMount.lua:273: in function 'RM_Object:SummonMount'
user:/AddOns/RandomMount/RandomMount.lua:198: in function 'func'
EsoUI/Libraries/Globals/globalapi.lua:207: in function '(anonymous)'

What is really irritating me is that it's only happening on the newly created necromancer. I don't use account wide settings, but i think the settings are the same, only different mounts selected per character.
Thanks for the info Sylow

Yeah, I never expected mounts to go away once they were learned. I will have to alter a little logic in RandomMount to be able to both add new mounts and remove ones.
Report comment to moderator  
Reply With Quote
Unread 05/21/19, 06:46 PM  
Weolo
AddOn Author - Click to view AddOns

Forum posts: 78
File comments: 430
Uploads: 4
Originally Posted by Sylow
I currently have a very strange thing. I have several characters but ONLY on my newly created character (Necromancer) this happens. When i try to edit among which mounts the addon should randomzie, i get the message "[LAM2] Cound not creatae checkbox 'Nascent Indrik' of RandomMountOptions."

On the indrik: i had the one mentioned, but i during the last event eveolved it to the luminous version. Also, for this character mounts are not being randomzied. First simply nothing happens. After zoning, i keep getting this error message:

user:/AddOns/RandomMount/RandomMount.lua:260: attempt to index a nil value
stack traceback:
user:/AddOns/RandomMount/RandomMount.lua:260: in function 'RM_Object:GetUseableMounts'
user:/AddOns/RandomMount/RandomMount.lua:273: in function 'RM_Object:SummonMount'
user:/AddOns/RandomMount/RandomMount.lua:198: in function 'func'
EsoUI/Libraries/Globals/globalapi.lua:207: in function '(anonymous)'

What is really irritating me is that it's only happening on the newly created necromancer. I don't use account wide settings, but i think the settings are the same, only different mounts selected per character.
Thanks for the info Sylow

Yeah, I never expected mounts to go away once they were learned. I will have to alter a little logic in RandomMount to be able to both add new mounts and remove ones.
Report comment to moderator  
Reply With Quote
Unread 05/21/19, 03:46 PM  
Sylow

Forum posts: 0
File comments: 2
Uploads: 0
I currently have a very strange thing. I have several characters but ONLY on my newly created character (Necromancer) this happens. When i try to edit among which mounts the addon should randomzie, i get the message "[LAM2] Cound not creatae checkbox 'Nascent Indrik' of RandomMountOptions."

On the indrik: i had the one mentioned, but i during the last event eveolved it to the luminous version. Also, for this character mounts are not being randomzied. First simply nothing happens. After zoning, i keep getting this error message:

user:/AddOns/RandomMount/RandomMount.lua:260: attempt to index a nil value
stack traceback:
user:/AddOns/RandomMount/RandomMount.lua:260: in function 'RM_Object:GetUseableMounts'
user:/AddOns/RandomMount/RandomMount.lua:273: in function 'RM_Object:SummonMount'
user:/AddOns/RandomMount/RandomMount.lua:198: in function 'func'
EsoUI/Libraries/Globals/globalapi.lua:207: in function '(anonymous)'

What is really irritating me is that it's only happening on the newly created necromancer. I don't use account wide settings, but i think the settings are the same, only different mounts selected per character.
Last edited by Sylow : 05/21/19 at 03:47 PM.
Report comment to moderator  
Reply With Quote
Unread 05/18/19, 01:47 PM  
Weolo
AddOn Author - Click to view AddOns

Forum posts: 78
File comments: 430
Uploads: 4
Originally Posted by Golconda
First off, I love this addon, thank you so much but ever since I switched to settings same on all characters it never chooses a new mount when I zone or dismount and I have tried turning it off and on again. I have tried reloading and I still get stuck with whatever mount I have at login. Just wondered if my settings are missing something.
I will have a look and see

@Golconda

I just tested Random Mount again to make sure and the addon is working fine for me. Mounts and pets are being summoned.

Can you make sure you have the latest version of LibAddonMenu
And when you switch to account settings, check that you have a few mounts turned on under the Random Mount options

If its still not working for you can you give me detailed steps on what you are doing and what happens, or doesnt happen
Last edited by Weolo : 05/18/19 at 11:30 PM.
Report comment to moderator  
Reply With Quote
Unread 05/18/19, 07:20 AM  
Golconda

Forum posts: 0
File comments: 42
Uploads: 0
First off, I love this addon, thank you so much but ever since I switched to settings same on all characters it never chooses a new mount when I zone or dismount and I have tried turning it off and on again. I have tried reloading and I still get stuck with whatever mount I have at login. Just wondered if my settings are missing something.
Report comment to moderator  
Reply With Quote
Unread 05/08/19, 03:34 PM  
Destrolly

Forum posts: 3
File comments: 2
Uploads: 0
Fixed

Originally Posted by Weolo
Hi Destrolly

Nice number of mounts! well done.

I bet it's down to the version of LibAddonMenu which is loading.
That might be easier to say than fix.
First make sure you have the latest version of LibAddonMenu installed separately, its currently 2.0 r29

More than likely its this tho..

Let me know how that goes. Libraries can be a pain at the moment but things are improving.
That was it! I reinstalled LibAddonMenu and now it works again - Awesome.

Thank you.
Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: