Quantcast
Download
(16 Kb)
Download
Updated: 06/18/19 06:55 AM
Pictures
File Info
Compatibility:
Elsweyr (5.0.5)
Wrathstone (4.3)
Murkmire (4.2)
Wolfhunter (4.1)
Summerset (4.0)
Dragon Bones (3.3)
Clockwork City (3.2)
Horns of the Reach (3.1)
Morrowind (3.0)
Homestead (2.7)
One Tamriel (2.6)
Shadows of the Hist (2.5)
Dark Brotherhood (2.4)
Thieves Guild (2.3)
Orsinium (2.2.4)
Updated:06/18/19 06:55 AM
Created:05/11/15 01:10 PM
Monthly downloads:3,868
Total downloads:150,386
Favorites:225
MD5:
Categories:Combat Mods, Bags, Bank, Inventory, Casting Bars, Cooldowns, PvP
Auto Recharge  Popular! (More than 5000 hits)
Version: 2.61
by: XanDDemoX, Baertram
Recharges and repairs your equipped weapons and amour automatically upon entering and leaving combat.

A single soul gem will be consumed per weapon recharged in the order of worst to best (e.g lesser soul gems will be used before common).

A single repair kit will be consumed per piece of armour recharged in the order of worst to best (e.g common repair kits will be used before greater).

Features
-Recharge weapons if the charge drops below a threshold
-Repair equipment if they drop below a threshold
-Remind me after login/as fight ends if my soul gems drop below a threshold
-Remind me after login/as fight ends if my repair kits drop below a threshold
-Show my number of repair kits left at a vendor
-Show info about what happened in the chat
-Suppress chat messages if nothing was done etc.
-Multi language support was added

Usage
You are able to setup everything in the LAM settings menu.

Automatic Charging
/arc Attempts to recharge the currently equipped primary and secondary weapons.
/arc + Enable automatic equipped weapons recharging (you can also use the localized value on, an, на).
/arc - Disable automatic equipped weapons recharging (you can also use the localized value off, aus, от).
/arc 0-99 Set the minimum charge percentage

Automatic Repair
/arp Attempts to repair the currently equipped armour.
/arp + Enable automatic amour repairing (you can also use the localized value on, an, на).
/arp - Disable automatic armour repairing (you can also use the localized value off, aus, от).
/arp 0-99 Set the minimum condition percentage

Many thanks to XanDDemoX for the base of this great helper!
And many thanks to Scootworks for helping me test and translate the addon!
Version 2.61
-Fixed chat commands /arc on and /arc off
-Fixed chat commands /arp on and /arp off
-Added the values an/aus and на/от to support German and Russian languages for the chat commands

Version 2.60
Removed: The needed libraries were removed from this addon and need to be installed seperately as standalone version: LibAddonMenu-2.0
Added: Chat output will not be shown anymore for empty soulgem/repair kits messages if you got 0 soulgems/repair kits and the setting to suppress the "nothing repaired/charged" is enabled.


Version 2.54
Fixed: The repair kits left icon was shown too far to the right when using the quickslot vendor from the crown store.
Updated: libAddonMenu r25
Updated: API

Version 2.51
Added single keybinds for "Repair" and "Recharge"

Version 2.41
Fixed typo

Version 2.4
-Api raise to Homestead
-Updated library LAM

Version 2.3
- Fixed lua error message
Version 2.2
- Added setting to switch to account wide settings (Thanks to Scootworks!)
- Added setting to show icon + repair kits left amount at a vendor's top-left corner
- Fixed bug where soul gems / repair kits amount was calculated false (always the total available sum was used
for single stacks of items, even if they were the same item like another stack)

Version 2.1
- New addon co-author: Baertram
- Updated Api version
- Updated libraries
- Added multi language support
- Added new settings (chat output, reminders for low repair kits/soul gems)
- Fixed some bugs
- Improved code where possible

Version 2.0.5

- Updated Api version to 100012

Version 2.0.4

- Added settings menu implementation by Baertram.

Version 2.0.3

- Fixed Off Hand slots not being checked for repair.

Version 2.0.2

- Renamed Readme.txt to README to prevent ESO detecting it as an addon

Version 2.0.1

- Fixed error attempting to enable / disable using slash commands.

Version 2.0.0

- Implemented Automatic amour repair
- Fixed potentially not searching all bag slots for items.

Version 1.0.7

- Fixed missing local definition in master weapon exclusion.

Version 1.0.6

- Added check of whether the player is dead before attempting to recharge.
- Added fixed Master weapon exclusion.

Version 1.0.5

- Increased settings version

Version 1.0.4

- Restored original settings variable name

Version 1.0.3

- Moved Readme and Licence into Recharge folder within zip for users who use Minion.

Version 1.0.2

- Disabled master weapons exclusion.

Version 1.0.1

- Added master weapons exclusion.

Version 0.0.6

- Added string trim to input to remove whitespace before attempting to parse a potentially numeric input

Version 0.0.5

- Enabled setting of a minimum charge percentage.

Version 0.0.4

- Initial Release
Optional Files (0)


Archived Files (21)
File Name
Version
Size
Uploader
Date
2.60
16kB
Baertram
05/31/19 10:39 AM
2.54
59kB
Baertram
01/27/18 08:23 PM
2.51
58kB
Baertram
09/07/17 02:28 PM
2.41
56kB
Baertram
07/04/17 01:49 PM
2.4
57kB
Baertram
02/06/17 02:34 PM
2.3
54kB
Baertram
11/21/16 03:46 PM
2.2
54kB
Baertram
11/20/16 01:56 PM
2.1
52kB
Baertram
11/12/16 02:52 PM
2.0.5
42kB
XanDDemoX
09/08/15 02:08 PM
2.0.4
42kB
XanDDemoX
08/12/15 03:04 PM
2.0.3
7kB
XanDDemoX
08/11/15 01:25 PM
2.0.2
6kB
XanDDemoX
05/23/15 01:07 AM
2.0.1
6kB
XanDDemoX
05/22/15 09:58 PM
1.0.7
5kB
XanDDemoX
05/20/15 09:41 PM
1.0.6
4kB
XanDDemoX
05/20/15 09:16 PM
1.0.5
4kB
XanDDemoX
05/18/15 10:41 PM
1.0.4
4kB
XanDDemoX
05/18/15 10:00 PM
1.0.3
4kB
XanDDemoX
05/18/15 08:10 PM
1.0.2
4kB
XanDDemoX
05/18/15 04:28 PM
0.0.6
4kB
XanDDemoX
05/18/15 02:12 PM
0.0.5
3kB
XanDDemoX
05/17/15 07:36 PM


Post A Reply Comment Options
Unread 10/16/19, 09:33 AM  
Baertram
 
Baertram's Avatar
AddOn Author - Click to view AddOns

Forum posts: 2419
File comments: 2695
Uploads: 57
Originally Posted by Daemok
Originally Posted by Baertram
Send me your SavedVariables please, if even the new ones do not work...
Sent to your email.
Have tested with the SavedVars from your mail but could not rebuild the problem so far.
Any further steps/info what to do where to get it happen? Like login with one char and then another, or any other details?

Maybe the one where it does not work got some other addons active which make it fail? Or do both chars use the same addons with the same settings?
Report comment to moderator  
Reply With Quote
Unread 10/03/19, 09:21 AM  
Daemok

Forum posts: 0
File comments: 46
Uploads: 0
Originally Posted by Baertram
Send me your SavedVariables please, if even the new ones do not work...
Sent to your email.
Report comment to moderator  
Reply With Quote
Unread 10/03/19, 06:38 AM  
Baertram
 
Baertram's Avatar
AddOn Author - Click to view AddOns

Forum posts: 2419
File comments: 2695
Uploads: 57
The version is no problem it's only inetrnally used and if it changes the SV will be totally deleted. But it won't change if you do not change it in the code.

Send me your SavedVariables please, if even the new ones do not wor.
And you are using account wide settings you said, or character settings?
Tell me (in the mail) the @account and 2 characters where it does not work.

So I can exchange your @account with mine and the character name (if character settings are used) with mine (or their id with 2 of mine) and test it with your settings then.

Originally Posted by Daemok
Tried various things to trouble shoot, including disabling all other addons. Also tried copying the account wide settings to the character settings in saved variables so they matched. Nothing is working

Strange thing is, I've also tried Personal Assistants auto repair, and it also will not warn me when low on kits. Is there some setting in game that might be preventing addons from printing messages on my screen?

I do see something a little strange in the SV, character settings read version = 2.1, account settings read version = 1.
Report comment to moderator  
Reply With Quote
Unread 10/02/19, 11:23 PM  
Daemok

Forum posts: 0
File comments: 46
Uploads: 0
Tried various things to trouble shoot, including disabling all other addons. Also tried copying the account wide settings to the character settings in saved variables so they matched. Nothing is working

Strange thing is, I've also tried Personal Assistants auto repair, and it also will not warn me when low on kits. Is there some setting in game that might be preventing addons from printing messages on my screen?

I do see something a little strange in the SV, character settings read version = 2.1, account settings read version = 1.
Report comment to moderator  
Reply With Quote
Unread 10/02/19, 10:28 PM  
Daemok

Forum posts: 0
File comments: 46
Uploads: 0
Sorry, I deleted those SavedVariables to see if that fixed the problem. It doesn't have seemed to, I'm getting no on-screen warnings for below threshold items or empty items. I have turned every option on to test, carrying various amount of kits. I get no warnings in or out of combat.

No idea what's going on. I should at least be seeing some warnings when carrying no kits at all. I was able to see some warnings on one character before I deleted the SV, but now neither character is showing warnings, maybe there is something wrong with how the addon handles Account Wide settings?
Report comment to moderator  
Reply With Quote
Unread 10/02/19, 01:31 PM  
Baertram
 
Baertram's Avatar
AddOn Author - Click to view AddOns

Forum posts: 2419
File comments: 2695
Uploads: 57
Originally Posted by Daemok
For some reason the login reminders are only working for one of my characters and not the other, even though I have account wide settings turned on.
Send me your SavedVariables file please as email to [email protected].
Please provide info in this email which server, accountName and characters you meant. The one where it works and the one where it doesn't.
Thank you.
Report comment to moderator  
Reply With Quote
Unread 10/02/19, 01:06 PM  
Daemok

Forum posts: 0
File comments: 46
Uploads: 0
For some reason the login reminders are only working for one of my characters and not the other, even though I have account wide settings turned on.
Report comment to moderator  
Reply With Quote
Unread 06/18/19, 06:29 AM  
Baertram
 
Baertram's Avatar
AddOn Author - Click to view AddOns

Forum posts: 2419
File comments: 2695
Uploads: 57
Re: Error when using /arc on

Seems there is a bug in the coding. /arc on or /arc off will always try to use on or off as a pecentage value...
Will fix this.

Originally Posted by Niverive
Getting this error whenever I try to use the /arc on or /arc off commands. The menu setting works without any issues. Thank you for the time you put into working on add-ons.



Link to photo for easier reading
https://photos.app.goo.gl/mGg1GVJ1qnxmU6n99
Last edited by Baertram : 06/18/19 at 06:29 AM.
Report comment to moderator  
Reply With Quote
Unread 06/15/19, 01:01 AM  
Niverive

Forum posts: 0
File comments: 4
Uploads: 0
Error when using /arc on

Getting this error whenever I try to use the /arc on or /arc off commands. The menu setting works without any issues. Thank you for the time you put into working on add-ons.



Link to photo for easier reading
https://photos.app.goo.gl/mGg1GVJ1qnxmU6n99
Last edited by Niverive : 06/15/19 at 01:05 AM.
Report comment to moderator  
Reply With Quote
Unread 05/31/19, 03:02 AM  
Baertram
 
Baertram's Avatar
AddOn Author - Click to view AddOns

Forum posts: 2419
File comments: 2695
Uploads: 57
Well this shouldn't happen. If the setting to disable the chat warning does jot work it's a bug.
I'll have a look after my vacations. You could search the Recharge.lua file for the text which is shown in the chat, or something like d(GetString(...)) where the... In th () sounds lika a placeholder for the warning, and put -- in front of it to comment the output.

I've checked the addon and found out if you change the "Chatoutput" setting to off the chat output will be off
So this would be possibility 1 and works as designed.

At another place where the string constant SI_ARC_ALERT_REPAIRKITS_EMPTY = "Repair kits are empty" was shown, each time it tries to repair something and there are 0 kits, I've changed it to not show any output if the setting to suppress "Nothing charged/repaired" text is enabled AND if chat output is enabled AND if the setting to alert for empty repair kits is enabled as well.

The same for the soulgem empty alters and their related settings.

Originally Posted by EQBallzz
Originally Posted by Baertram
Originally Posted by EQBallzz
Originally Posted by Baertram
Originally Posted by EQBallzz
I keep getting spammed with "AutoRecharge repair kits are empty!" messages even though I have all of those off in the addon settings. Is anyone else getting this or know of a workaround to make it stop? I tried turning it on and off but that didn't work.
Which repair kits are you using? The crown store repair kits are not workign the same way so they are not supported.
If you got other repair kits (small, large, etc.) it should work just fine.
These errors were on a new character with no repair kits but I turned off the messages associated with being empty of kits (I think) so I assumed this would suppress this spam?
Right, that makes sense
If the addon is enabled it will warn you. That's its purpose.
I thought the addon purpose was to automatically recharge which is what I want it to do *if* I have the kits. There are options in the addon to suppress these kit "empty" messages but it doesn't seem to suppress them. It's doing more than warning..it's literally spamming the entire chat window.
Last edited by Baertram : 05/31/19 at 10:35 AM.
Report comment to moderator  
Reply With Quote
Unread 05/31/19, 12:56 AM  
EQBallzz

Forum posts: 9
File comments: 209
Uploads: 0
Originally Posted by Baertram
Originally Posted by EQBallzz
Originally Posted by Baertram
Originally Posted by EQBallzz
I keep getting spammed with "AutoRecharge repair kits are empty!" messages even though I have all of those off in the addon settings. Is anyone else getting this or know of a workaround to make it stop? I tried turning it on and off but that didn't work.
Which repair kits are you using? The crown store repair kits are not workign the same way so they are not supported.
If you got other repair kits (small, large, etc.) it should work just fine.
These errors were on a new character with no repair kits but I turned off the messages associated with being empty of kits (I think) so I assumed this would suppress this spam?
Right, that makes sense
If the addon is enabled it will warn you. That's its purpose.
I thought the addon purpose was to automatically recharge which is what I want it to do *if* I have the kits. There are options in the addon to suppress these kit "empty" messages but it doesn't seem to suppress them. It's doing more than warning..it's literally spamming the entire chat window.
Report comment to moderator  
Reply With Quote
Unread 05/30/19, 02:22 PM  
Baertram
 
Baertram's Avatar
AddOn Author - Click to view AddOns

Forum posts: 2419
File comments: 2695
Uploads: 57
Originally Posted by EQBallzz
Originally Posted by Baertram
Originally Posted by EQBallzz
I keep getting spammed with "AutoRecharge repair kits are empty!" messages even though I have all of those off in the addon settings. Is anyone else getting this or know of a workaround to make it stop? I tried turning it on and off but that didn't work.
Which repair kits are you using? The crown store repair kits are not workign the same way so they are not supported.
If you got other repair kits (small, large, etc.) it should work just fine.
These errors were on a new character with no repair kits but I turned off the messages associated with being empty of kits (I think) so I assumed this would suppress this spam?
Right, that makes sense
If the addon is enabled it will warn you. That's its purpose.
Last edited by Baertram : 05/30/19 at 02:23 PM.
Report comment to moderator  
Reply With Quote
Unread 05/29/19, 02:57 PM  
EQBallzz

Forum posts: 9
File comments: 209
Uploads: 0
Originally Posted by Baertram
Originally Posted by EQBallzz
I keep getting spammed with "AutoRecharge repair kits are empty!" messages even though I have all of those off in the addon settings. Is anyone else getting this or know of a workaround to make it stop? I tried turning it on and off but that didn't work.
Which repair kits are you using? The crown store repair kits are not workign the same way so they are not supported.
If you got other repair kits (small, large, etc.) it should work just fine.
These errors were on a new character with no repair kits but I turned off the messages associated with being empty of kits (I think) so I assumed this would suppress this spam?
Report comment to moderator  
Reply With Quote
Unread 05/29/19, 04:11 AM  
Baertram
 
Baertram's Avatar
AddOn Author - Click to view AddOns

Forum posts: 2419
File comments: 2695
Uploads: 57
Originally Posted by EQBallzz
I keep getting spammed with "AutoRecharge repair kits are empty!" messages even though I have all of those off in the addon settings. Is anyone else getting this or know of a workaround to make it stop? I tried turning it on and off but that didn't work.
Which repair kits are you using? The crown store repair kits are not workign the same way so they are not supported.
If you got other repair kits (small, large, etc.) it should work just fine.
Report comment to moderator  
Reply With Quote
Unread 05/28/19, 08:29 PM  
EQBallzz

Forum posts: 9
File comments: 209
Uploads: 0
I keep getting spammed with "AutoRecharge repair kits are empty!" messages even though I have all of those off in the addon settings. Is anyone else getting this or know of a workaround to make it stop? I tried turning it on and off but that didn't work.
Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: