Quantcast
Download
(23 Kb)
Download
Updated: 11/23/20 05:48 AM
Pictures
File Info
Compatibility:
Markarth (6.2.5)
Stonethorn (6.1.5)
Greymoor (6.0.5)
Updated:11/23/20 05:48 AM
Created:05/11/15 01:10 PM
Monthly downloads:8,979
Total downloads:351,380
Favorites:343
MD5:
Categories:Combat Mods, Bags, Bank, Inventory, Casting Bars, Cooldowns, PvP
6.2.5
Auto Recharge (and repair)  Popular! (More than 5000 hits)
Version: 2.68
by: XanDDemoX, Baertram
Recharges and repairs your equipped weapons and amour automatically upon entering and leaving combat.

A single soul gem will be consumed per weapon recharged in the order of worst to best (e.g lesser soul gems will be used before common).

A single repair kit will be consumed per piece of armour recharged in the order of worst to best (e.g common repair kits will be used before greater).

Features
-Recharge weapons if the charge drops below a threshold (at combat start, in combat, and after combat, optionally: As weapon pair changes)
-Repair equipment if they drop below a threshold (at combat start, in combat, and after combat, optionally: No crown repair kits will be used)
-Remind me after login/as fight ends if my soul gems drop below a threshold
-Remind me after login/as fight ends if my repair kits drop below a threshold
-Show my number of repair kits left at a vendor
-Show info about what happened in the chat
-Suppress chat messages if nothing was done etc.
-Multi language support was added

Usage
You are able to setup everything in the LAM settings menu.

Automatic Charging
/arc Attempts to recharge the currently equipped primary and secondary weapons.
/arc + Enable automatic equipped weapons recharging (you can also use the localized value on, an, на).
/arc - Disable automatic equipped weapons recharging (you can also use the localized value off, aus, от).
/arc 0-99 Set the minimum charge percentage

Automatic Repair
/arp Attempts to repair the currently equipped armour.
/arp + Enable automatic amour repairing (you can also use the localized value on, an, на).
/arp - Disable automatic armour repairing (you can also use the localized value off, aus, от).
/arp 0-99 Set the minimum condition percentage

Many thanks to XanDDemoX for the base of this great helper!
And many thanks to Scootworks for helping me test and translate the addon!
IMPORTANT: With version 2.67: The SavedVariables changed to server dependent ones.
You need to setup your SavedVariables new! LOGOUT and BACKUP your SavedVariables before updating from version 2.66


Version 2.68
-Fixed LAM settings checkbox for account wide settings to be saved server dependent
-> Please check your settings after updating to version 2.68 as this checkbox might be disabled!
-Fixed Cannot create LAM ... error message
-Fixed "this item is fully repaired" multiple messages


Version 2.67
-Tested on Markarth & Stonethorn
-Updated API and files
-Updated Russian translation (thanks to ivann339)
-Added speed up variables for settings
-Fixed slash commands and keybindings trying to access the non-loaded settings
-Fixed in combat repair/recharge
-Fixed event filters for recharge and repair not overwriting each other
-Added setting for "No crown store repair kits"
-Fixed: Crown store repair kits usage on 1 equipped item (will repair all then) instead of trying to use it as normal repair kit + checking other equipped items afterwards unnecessarily
-Fixed non-slotted items (2hd backup slot e.g.) -> No repair start anymore
-Fixed settings
-Added event filter on BAG_WORN for charge and repair checks
-Added setting to check weapon charge on weapon pair change + setting for only in combat

Version 2.66
-Updated API to Stonethorn
-Updated needed versions of dependencies
-Updated French translations (thanks to jakez31)

Version 2.65
-Removed LibStub hybrid call
-Added LibAddonMenu-2.0 Verison 28 or newer as dependency
-Fixed typo in event filter for charge change -> In combat charging did not work due to this

Version 2.64
-Removed additional debug messages

Version 2.63
-Updated API
-Removed debug messages

Version 2.62
-Updated API
-Added option: Recharge weapon during combat
-Added option: Repair armor during combat

Version 2.61
-Fixed chat commands /arc on and /arc off
-Fixed chat commands /arp on and /arp off
-Added the values an/aus and на/от to support German and Russian languages for the chat commands

Version 2.60
Removed: The needed libraries were removed from this addon and need to be installed seperately as standalone version: LibAddonMenu-2.0
Added: Chat output will not be shown anymore for empty soulgem/repair kits messages if you got 0 soulgems/repair kits and the setting to suppress the "nothing repaired/charged" is enabled.


Version 2.54
Fixed: The repair kits left icon was shown too far to the right when using the quickslot vendor from the crown store.
Updated: libAddonMenu r25
Updated: API

Version 2.51
Added single keybinds for "Repair" and "Recharge"

Version 2.41
Fixed typo

Version 2.4
-Api raise to Homestead
-Updated library LAM

Version 2.3
- Fixed lua error message
Version 2.2
- Added setting to switch to account wide settings (Thanks to Scootworks!)
- Added setting to show icon + repair kits left amount at a vendor's top-left corner
- Fixed bug where soul gems / repair kits amount was calculated false (always the total available sum was used
for single stacks of items, even if they were the same item like another stack)

Version 2.1
- New addon co-author: Baertram
- Updated Api version
- Updated libraries
- Added multi language support
- Added new settings (chat output, reminders for low repair kits/soul gems)
- Fixed some bugs
- Improved code where possible

Version 2.0.5

- Updated Api version to 100012

Version 2.0.4

- Added settings menu implementation by Baertram.

Version 2.0.3

- Fixed Off Hand slots not being checked for repair.

Version 2.0.2

- Renamed Readme.txt to README to prevent ESO detecting it as an addon

Version 2.0.1

- Fixed error attempting to enable / disable using slash commands.

Version 2.0.0

- Implemented Automatic amour repair
- Fixed potentially not searching all bag slots for items.

Version 1.0.7

- Fixed missing local definition in master weapon exclusion.

Version 1.0.6

- Added check of whether the player is dead before attempting to recharge.
- Added fixed Master weapon exclusion.

Version 1.0.5

- Increased settings version

Version 1.0.4

- Restored original settings variable name

Version 1.0.3

- Moved Readme and Licence into Recharge folder within zip for users who use Minion.

Version 1.0.2

- Disabled master weapons exclusion.

Version 1.0.1

- Added master weapons exclusion.

Version 0.0.6

- Added string trim to input to remove whitespace before attempting to parse a potentially numeric input

Version 0.0.5

- Enabled setting of a minimum charge percentage.

Version 0.0.4

- Initial Release
Optional Files (0)


Archived Files (28)
File Name
Version
Size
Uploader
Date
2.67
23kB
Baertram
10/17/20 01:04 PM
2.66
19kB
Baertram
09/19/20 09:04 AM
2.65
17kB
Baertram
03/21/20 08:41 PM
2.64
17kB
Baertram
02/26/20 04:08 AM
2.63
17kB
Baertram
02/24/20 05:14 PM
2.62
17kB
Baertram
02/23/20 07:12 PM
2.61
16kB
Baertram
06/18/19 06:55 AM
2.60
16kB
Baertram
05/31/19 10:39 AM
2.54
59kB
Baertram
01/27/18 08:23 PM
2.51
58kB
Baertram
09/07/17 02:28 PM
2.41
56kB
Baertram
07/04/17 01:49 PM
2.4
57kB
Baertram
02/06/17 02:34 PM
2.3
54kB
Baertram
11/21/16 03:46 PM
2.2
54kB
Baertram
11/20/16 01:56 PM
2.1
52kB
Baertram
11/12/16 02:52 PM
2.0.5
42kB
XanDDemoX
09/08/15 02:08 PM
2.0.4
42kB
XanDDemoX
08/12/15 03:04 PM
2.0.3
7kB
XanDDemoX
08/11/15 01:25 PM
2.0.2
6kB
XanDDemoX
05/23/15 01:07 AM
2.0.1
6kB
XanDDemoX
05/22/15 09:58 PM
1.0.7
5kB
XanDDemoX
05/20/15 09:41 PM
1.0.6
4kB
XanDDemoX
05/20/15 09:16 PM
1.0.5
4kB
XanDDemoX
05/18/15 10:41 PM
1.0.4
4kB
XanDDemoX
05/18/15 10:00 PM
1.0.3
4kB
XanDDemoX
05/18/15 08:10 PM
1.0.2
4kB
XanDDemoX
05/18/15 04:28 PM
0.0.6
4kB
XanDDemoX
05/18/15 02:12 PM
0.0.5
3kB
XanDDemoX
05/17/15 07:36 PM


Post A Reply Comment Options
Unread 01/16/21, 08:05 PM  
Baertram
 
Baertram's Avatar
AddOn Author - Click to view AddOns

Forum posts: 3282
File comments: 3986
Uploads: 64
Re: Use Crown Kits 1st?

Originally Posted by mythbinder
Is there away to force this to use my Crown repair kits 1st?
These are really piling up from daily gifts..
It should automatically use them if you haven't disabled it in the settings.
Maybe also disable "Use repair kit for item level" to make sure it does not check the repair value and just uses any kit given.
Normally the kit used should be he one from the top of the repair kits stack, starting with the crown ones (afaik).
Report comment to moderator  
Reply With Quote
Unread 01/16/21, 06:57 PM  
mythbinder

Forum posts: 0
File comments: 5
Uploads: 0
Use Crown Kits 1st?

Is there away to force this to use my Crown repair kits 1st?
These are really piling up from daily gifts..
Report comment to moderator  
Reply With Quote
Unread 01/11/21, 03:38 PM  
Quido

Forum posts: 0
File comments: 2
Uploads: 0
Re: Auto repairing when I talk to merchant

Originally Posted by Quido
Thank you for making this addon, I'm using this well a lot. And.. I think repairing cost of merchant npc is too high, so I hope this addon have an option which disable auto repairng when I talk to merchant npc
oh I realized it's alpha gear's function. sorry
Report comment to moderator  
Reply With Quote
Unread 01/08/21, 09:30 AM  
Baertram
 
Baertram's Avatar
AddOn Author - Click to view AddOns

Forum posts: 3282
File comments: 3986
Uploads: 64
Re: Auto repairing when I talk to merchant

Originally Posted by Quido
Thank you for making this addon, I'm using this well a lot. And.. I think repairing cost of merchant npc is too high, so I hope this addon have an option which disable auto repairng when I talk to merchant npc
There is no auto repairing if you talk to any merchant within the vanilla UI?
You need to click on the repair button or use the keybind "manually".

If this happens automatically it's another addon, so just disable your addons and check which one does this auto repair at vendors NPCs.
You should ALWAYS disable ALL addons please and ONLY test with the 1 addon you are requesting to have features for/reporting a bug.

Please read this -> Especially the part "How to report a lua error message/a bug to the developers"
https://www.esoui.com/forums/showthread.php?t=8858

Same applies to new feature requests. It takes use too much time to find out stuff if you do not disable all other addons before.
The only thing where other addons need to be enabled is, if you know which addon causes something (error, supportes feature) and you are explicitly askng for a fix/feature WITH that other addon in combination.

Many thanks.
Last edited by Baertram : 01/08/21 at 09:31 AM.
Report comment to moderator  
Reply With Quote
Unread 01/08/21, 08:09 AM  
Quido

Forum posts: 0
File comments: 2
Uploads: 0
Auto repairing when I talk to merchant

Thank you for making this addon, I'm using this well a lot. And.. I think repairing cost of merchant npc is too high, so I hope this addon have an option which disable auto repairng when I talk to merchant npc
Report comment to moderator  
Reply With Quote
Unread 12/13/20, 06:51 AM  
Baertram
 
Baertram's Avatar
AddOn Author - Click to view AddOns

Forum posts: 3282
File comments: 3986
Uploads: 64
Re: Re: Re: Neue Meldung

Hi Neverlands,

what did change then? Did you update any other addons which might be the reason?
I haven't had the message anymore since version 2.68, nevertheless if CrownRepair kits or non-crown repair kits are used.

Are you able to rebuild it somehow with only AR enabled? e.g. set the repair threshold to 99% and fight a bit until items get damaged.
What is your current threshold % value? Maybe it depends on the value you have set. I'm using 50% so it will repair if items get damaged below that value. Could be even less but I'm not sure if we get less set item benefitif the items are damaged too much? There is somehting shown "with stars", never really looked into this, if this affects the dmg output/taken as well if you got e.g. only 2/3 stars.

Originally Posted by Neverlands
Originally Posted by Baertram
Originally Posted by Neverlands
Hello,
lately I get this message "Dieser Gegenstand ist schon völlig in Ordnung" (something like "This item is already perfectly ok" in English) after an armor repair. Is it from this addon or from ESO itself?

It's the standard ESO vanilla UI message shown at the top right corner of the screen, if something is trying to repair an item which is at 100%. You can try it yourself manually with any repair kit or a crown repair kit e.g.
But it could be that AR is trying to repair an item which is at 100% already, though this message then should only happen if a crown repair kit was used. Did you choose to let AR use Crown Repair kits and it's used as any other equipped item was at 100% already?
Or did you disable the crown repair kit usage?

If crown repair kit usage was disabled this message shouldn't appear as the items which get repaired are repaired by normal repair kits and if the item is at 100% already it won't be tried to repair anymore.
Hello Baertram,
sorry for the late reply. In fact I never use Crown Repair kits - I keep them in the house storage.
Originally Posted by Baertram
Version 2.68
-Fixed LAM settings checkbox for account wide settings to be saved server dependent
-> Please check your settings after updating to version 2.68 as this checkbox might be disabled!
-Fixed Cannot create LAM ... error message
-Fixed "this item is fully repaired" multiple messages
After this update I didn't receive the message anymore, but now- for any reason - it's back again.
Report comment to moderator  
Reply With Quote
Unread 12/13/20, 04:28 AM  
Neverlands
 
Neverlands's Avatar

Forum posts: 6
File comments: 185
Uploads: 0
Re: Re: Neue Meldung

Originally Posted by Baertram
Originally Posted by Neverlands
Hello,
lately I get this message "Dieser Gegenstand ist schon völlig in Ordnung" (something like "This item is already perfectly ok" in English) after an armor repair. Is it from this addon or from ESO itself?

It's the standard ESO vanilla UI message shown at the top right corner of the screen, if something is trying to repair an item which is at 100%. You can try it yourself manually with any repair kit or a crown repair kit e.g.
But it could be that AR is trying to repair an item which is at 100% already, though this message then should only happen if a crown repair kit was used. Did you choose to let AR use Crown Repair kits and it's used as any other equipped item was at 100% already?
Or did you disable the crown repair kit usage?

If crown repair kit usage was disabled this message shouldn't appear as the items which get repaired are repaired by normal repair kits and if the item is at 100% already it won't be tried to repair anymore.
Hello Baertram,
sorry for the late reply. In fact I never use Crown Repair kits - I keep them in the house storage.
Originally Posted by Baertram
Version 2.68
-Fixed LAM settings checkbox for account wide settings to be saved server dependent
-> Please check your settings after updating to version 2.68 as this checkbox might be disabled!
-Fixed Cannot create LAM ... error message
-Fixed "this item is fully repaired" multiple messages
After this update I didn't receive the message anymore, but now- for any reason - it's back again.
Report comment to moderator  
Reply With Quote
Unread 11/23/20, 05:49 AM  
Baertram
 
Baertram's Avatar
AddOn Author - Click to view AddOns

Forum posts: 3282
File comments: 3986
Uploads: 64
IMPORTANT: With version 2.67: The SavedVariables changed to server dependent ones.
You need to setup your SavedVariables new! LOGOUT and BACKUP your SavedVariables before updating from version 2.66


Version 2.68
-Fixed LAM settings checkbox for account wide settings to be saved server dependent
-> Please check your settings after updating to version 2.68 as this checkbox might be disabled!
-Fixed Cannot create LAM ... error message
-Fixed "this item is fully repaired" multiple messages
Report comment to moderator  
Reply With Quote
Unread 11/21/20, 03:43 PM  
Baertram
 
Baertram's Avatar
AddOn Author - Click to view AddOns

Forum posts: 3282
File comments: 3986
Uploads: 64
Re: Re: Account-Wide Setting Error Message

Test with DE and EN client. No problems, all created properly within LAM.
With my normal install and a fresh installed version with deleted SavedVariables.
Using account wide or non account wide settings.
So far not able to rebuild this problem.

But I found out that this setting is not properly saving respecting the server so I need to fix this.
Worked on the multiple "already repaired" messages, hopefully they are fixed as well with the current beta version.
Last edited by Baertram : 11/23/20 at 05:49 AM.
Report comment to moderator  
Reply With Quote
Unread 11/20/20, 03:16 AM  
Baertram
 
Baertram's Avatar
AddOn Author - Click to view AddOns

Forum posts: 3282
File comments: 3986
Uploads: 64
Re: Account-Wide Setting Error Message

Originally Posted by ANewHand
Hello,
I love the addon, it seems to be working fine for me but whenever I open settings I keep getting an error message that LibAddonMenu 2.0 is unable to create the checkbox "Use accountwide settings". I've disabled all mods and reset my saved vars but it still popped up. So far it seems all my characters have inherited accountwide settings, which is fine for me, but I'm a little tired of seeing the error prompt. Obviously I haven't seen any checkbox for accountwide settings.
Anyways it's a very minor thing, otherwise your addon's amazing thank you so much!

Hm, this would only happen if the SavedVariables files are somehow broken.
Could you please logout, and navigate with the file explorer to the SV folder (read here how to find it, normally it's c:\users\your windows username\documents\elder scrolls online\live\SavedVariables), and then backup the file Recharge.lua.
Then send me this file to my email: [email protected] and please write me which server, @accountName and which characterName the problem occurs with.
I'll test with your settings file then if I'm able to see what is wrong and if I can fix this.

You could try meanwhile, after sending me your SV file AND having done a backup of it, to delete the file (keep the backup) and then login again and reconfigure the addon. Does the error message disappear then and is all fine?
Report comment to moderator  
Reply With Quote
Unread 11/20/20, 01:44 AM  
ANewHand

Forum posts: 0
File comments: 1
Uploads: 0
Account-Wide Setting Error Message

Hello,
I love the addon, it seems to be working fine for me but whenever I open settings I keep getting an error message that LibAddonMenu 2.0 is unable to create the checkbox "Use accountwide settings". I've disabled all mods and reset my saved vars but it still popped up. So far it seems all my characters have inherited accountwide settings, which is fine for me, but I'm a little tired of seeing the error prompt. Obviously I haven't seen any checkbox for accountwide settings.
Anyways it's a very minor thing, otherwise your addon's amazing thank you so much!

Report comment to moderator  
Reply With Quote
Unread 11/14/20, 02:07 PM  
Mzark

Forum posts: 0
File comments: 5
Uploads: 0
misspells

there are some typos in the messages the addon gives. like the one shown in the screenshot. COuld you please correct this? Thanks! The addon ROCKS!
Report comment to moderator  
Reply With Quote
Unread 10/25/20, 07:33 AM  
Baertram
 
Baertram's Avatar
AddOn Author - Click to view AddOns

Forum posts: 3282
File comments: 3986
Uploads: 64
Re: Neue Meldung

Originally Posted by Neverlands
Hello,
lately I get this message "Dieser Gegenstand ist schon völlig in Ordnung" (something like "This item is already perfectly ok" in English) after an armor repair. Is it from this addon or from ESO itself?
It's the standard ESO vanilla UI message shown at the top right corner of the screen, if something is trying to repair an item which is at 100%. You can try it yourself manually with any repair kit or a crown repair kit e.g.

But it could be that AR is trying to repair an item which is at 100% already, though this message then should only happen if a crown repair kit was used. Did you choose to let AR use Crown Repair kits and it's used as any other equipped item was at 100% already?
Or did you disable the crown repair kit usage?

If crown repair kit usage was disabled this message shouldn't appear as the items which get repaired are repaired by normal repair kits and if the item is at 100% already it won't be tried to repair anymore.
Last edited by Baertram : 10/25/20 at 07:34 AM.
Report comment to moderator  
Reply With Quote
Unread 10/24/20, 03:57 PM  
Neverlands
 
Neverlands's Avatar

Forum posts: 6
File comments: 185
Uploads: 0
Neue Meldung

Hello,
lately I get this message "Dieser Gegenstand ist schon völlig in Ordnung" (something like "This item is already perfectly ok" in English) after an armor repair. Is it from this addon or from ESO itself?
Report comment to moderator  
Reply With Quote
Unread 10/17/20, 01:04 PM  
Baertram
 
Baertram's Avatar
AddOn Author - Click to view AddOns

Forum posts: 3282
File comments: 3986
Uploads: 64
Version 2.67
IMPORTANT: The SavedVariables changed to server dependent ones.
You need to setup your SavedVariables new!


-Tested on Markarth & Stonethorn
-Updated API and files
-Updated Russian translation (thanks to ivann339)
-Added speed up variables for settings
-Fixed slash commands and keybindings trying to access the non-loaded settings
-Fixed in combat repair/recharge
-Fixed event filters for recharge and repair not overwriting each other
-Added setting for "No crown store repair kits"
-Added: Crown store repair kits usage on 1 equipped item (will repair all then) instead of trying to use it as normal repair kit + checking other equipped items afterwards unnecessarily
-Fixed non-slotted items (2hd backup slot e.g.) -> No repair start anymore
-Fixed settings
-Added event filter on BAG_WORN for charge and repair checks
-Added setting to check weapon charge on weapon pair change + setting for only in combat
Last edited by Baertram : 10/17/20 at 01:05 PM.
Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: