Thread Tools Display Modes
02/19/24, 01:32 PM   #1
IsharaMeradin
 
IsharaMeradin's Avatar
Join Date: Jan 2018
Posts: 8
Unsure of error source

Not sure of the source of this. I used the ragpicker NPC that I had placed in my home to deconstruct the items in my inventory. I had three items. I do not recall what they were to be honest. I immediately received the following:
Warning: Spoiler


Inspecting the interface.log file found in the "Documents\Elder Scrolls Online\live\logs" folder I found this repeating until I logged out a few minutes later:
Warning: Spoiler


I checked on my addons and had quite a few that needed updated due to the recent PTS release of the next DLC. I have updated them. No idea if that would help or not.

It should be noted that I had used the exact same ragpicker NPC in my home earlier with the same character and had no issues. Plus based on what I am reading, I suspect that I had an axe that was deconstructed and something about it triggered this error.

Possible sources of the aforementioned axe: Somewhere in IC. I had done some master writs, one of which was located in IC. IC was the only location where I fought enemies in order to access the set stations.

If someone more knowledgeable in the game's inner workings could figure out the issue and
1) let me know how to prevent it going forward
2) if it is a bug that should be reported to ZOS
  Reply With Quote
02/19/24, 05:20 PM   #2
Baertram
Super Moderator
 
Baertram's Avatar
WoWInterface Super Mod
AddOn Author - Click to view addons
Join Date: Mar 2014
Posts: 4,952
https://www.esoui.com/forums/showthread.php?t=8858
Read below, and ff

"lua error messages ingame - How do I read them?"

Try to use LibDebugLogger like described here, to protocoll the addons and libraries used.
If the error happens again this could help to find out if it's addon related, or not.
  Reply With Quote
02/20/24, 07:53 AM   #3
Sharlikran
 
Sharlikran's Avatar
AddOn Author - Click to view addons
Join Date: Apr 2014
Posts: 638
While that link that was provided will have some helpful information about ways to read through the errors so you know which mod it is IsharaMeradin, I skimmed over them already and they all seem to be referring to internal zos code. Simply put an author isn't using the API properly.

The only real way is to disable sections of mods until it stops happening. Then enable them until you find the one causing the issue.

https://sir.insidi.at/or/logviewer/

You can drag and drop a copy of your LibDebugLogger.lua from SavedVariables to that site and click Upload to provide a link. However, I don't know if I will see any other information from the stack trace that would help.

Last edited by Sharlikran : 02/20/24 at 02:41 PM.
  Reply With Quote

ESOUI » AddOns » AddOn Help/Support » Unsure of error source

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off