Quantcast
Download
(26 Kb)
Download
Updated: 03/26/20 10:28 AM
Pictures
File Info
Compatibility:
Harrowstorm (5.3.4)
Updated:03/26/20 10:28 AM
Created:03/05/20 09:49 AM
Monthly downloads:542
Total downloads:547
Favorites:6
MD5:
5.3.4
ESO Farm-Buddy  Updated this week!
Version: 1.0.3
by: Keldor [More]
Supported languages: EN, DE, FR
You want to contribute to the translation? https://www.esoui.com/forums/showthread.php?t=8974

Important Prerequisites

Please install this libraries with Minion or download the libs from their project pages.




What It Does

You can track items in a special window to keep track over your farming progress. Just right click any item in your inventory or bank and select "Track with Farm-Buddy". Right click on any item in the list to set a goal count or to delete the item. There are various settings like notifications, bar colors etc.


Notes

In order to interact with the window, you have to lock the window in the ESO Farm-Buddy settings. I you want to move the window around, you have to unlock the window in the settings.


Features
  • Track item counts in your bag or crafting bag
  • Show a notification if the goal is reached
  • Visual display with progress bars
  • If you loot more than the defined goal count, a bonus value is displayed
  • Choose between different progress bar styles
  • Track items from your inventory by right click the item
  • Track items from the chat by right click the item link
  • Track items from the guild traders by right click the item

Chat commands
  • /efb track <Item Link> - Adds the given Item link to the list.
  • /efb remove <Item Link> - Removes the item link from the list.
  • /efb goal <Item Link> <Count> - Sets the goal count for an item link.
  • /efb clear - Removes all tracked items from the list.
  • /efb toggle lock - Toggles the lock state of the window between locked and unlocked.
  • /efb toggle title - Toggles the title display status of the window between shown and hidden.
  • /efb toggle progressbar - Toggles the progress bar display status for the item list.
  • /efb toggle bonus - Toggles the goal bonus display status for the item list.
  • /efb toggle notifications - Toggles the show notifications setting on or off.
  • /efb toggle includebank - Toggles the include bank to count setting.
  • /efb toggle includecraftbag - Toggles the include craft bag to count settings.
  • /efb toggle hide - Toggles the show window status.
  • /efb toggle clamptoscreen - Toggles the clamp to screen setting.
  • /efb toggle hidecombat - Toggles the hide window in combat setting.
  • /efb toggle hidedungeon - Toggles the hide window in dungeons and trials setting.
  • /efb toggle hidepvp - Toggles the hide window in PvP setting.
  • /efb toggle hidehomes - Toggles the hide in homes setting.
  • /efb toggle itemname - Toggles the show item name setting.
  • /efb toggle notificationsound - Toggles the play notification sound setting.
  • /efb notificationtest - Shows a test notification to test the notification settings.
  • /efb settings - Open the settings window.
  • /efb version - Shows the AddOn version.

TODO
  • Settings for font size and scaling
  • Setting to show/hide icon
# 1.0.3
- Refactored guild store context menu implementation

# 1.0.2
- Added the "Track with Farm-Buddy" context menu entry to guild trader result items

# 1.0.1
- Added /efb version chat command
- Added the "Track with Farm-Buddy" context menu entry to every item link context menu
- Changed the font of the textured progress bar

# 1.0.0
- Added progress bar style select
- Added setting to hide window in homes
- Added chat commands
- Fixed a bug where the window was movable when the lock state was active with no items in list
- Fixed an bug where removing and adding the same item could resulting in an empty row
- Fixed an bug where the goal window keeps open when the corresponding item was removed
- Fixed an bug where the exists check for controls not working as expected
- Using LibCustomMenu for the inventory context menu (Thanks Baertram)

# 0.6.0
- Added setting to toggle notification sound playback
- Added setting to show the window while in settings menu
- Added setting to adjust the background opacity
- Added a action button to the settings page to test the notification
- Added setting to change the goal display mode (Bonus percent or count)
- Rearranged settings menu
- Fixed a bug where the progress bar color has not changed

# 0.5.1
- Changed AddOn dependencies to a specific version of the libraries (Thanks to Baertram)
- Added missing translations for the goal window

# 0.5.0
- The first release of this addon
Archived Files (6)
File Name
Version
Size
Uploader
Date
1.0.2
26kB
Keldor
03/26/20 09:49 AM
1.0.1
26kB
Keldor
03/26/20 06:38 AM
1.0.0
25kB
Keldor
03/25/20 11:04 AM
0.6.0
20kB
Keldor
03/17/20 08:22 AM
0.5.1
18kB
Keldor
03/06/20 06:38 AM
0.5.0
18kB
Keldor
03/05/20 09:49 AM


Post A Reply Comment Options
Unread Yesterday, 12:01 PM  
Balmeri

Forum posts: 0
File comments: 21
Uploads: 0
Sorry it's taken me a while to get around to getting screenshots and coming to report this.

Since the last update adding a context menu item this addon has conflicted with at least one of my addons that adds context menu entries. I just went thru an exhausting trial and error thing with another addon to pin down it's conflicts, so I'm not up to working out what's actually happening, but thought I should point it out. The screenshots below show with ESO Farm Buddy active, where a few items overwrite each other and most don't get written at all, and the normal context menu I get without it active. I'm assuming some sort of closing state is expected by at least one other addon, maybe others check for a bad state and fix it, I don't know, just guessing.

Report comment to moderator  
Reply With Quote
Unread 03/26/20, 02:41 AM  
Keldor
 
Keldor's Avatar
AddOn Author - Click to view AddOns

Forum posts: 58
File comments: 15
Uploads: 2
Oh, thanks for the info! And many thanks for your support
__________________
ESO-Database.com | Character- and Guild Database [EN/DE] (System Status)
ESO-Skillfactory.com | ESO Build planer [EN/DE/FR]
ESO-LFG.com | The ESO Looking for Group Tool [EN/DE/FR]
Report comment to moderator  
Reply With Quote
Unread 03/25/20, 02:40 PM  
Baertram
 
Baertram's Avatar
AddOn Author - Click to view AddOns

Forum posts: 2708
File comments: 3230
Uploads: 57
Just a visual bug in the changelog LibAddonMenu -> LibCustomMenu

Thanks for using the proper library to support the other addons!
Last edited by Baertram : 03/25/20 at 02:40 PM.
Report comment to moderator  
Reply With Quote
Unread 03/18/20, 02:43 AM  
Keldor
 
Keldor's Avatar
AddOn Author - Click to view AddOns

Forum posts: 58
File comments: 15
Uploads: 2
Ah thanks for the info Baertram! I'll keep the >=30 to force the users to update their libs
__________________
ESO-Database.com | Character- and Guild Database [EN/DE] (System Status)
ESO-Skillfactory.com | ESO Build planer [EN/DE/FR]
ESO-LFG.com | The ESO Looking for Group Tool [EN/DE/FR]
Last edited by Keldor : 03/18/20 at 02:46 AM.
Report comment to moderator  
Reply With Quote
Unread 03/17/20, 11:48 AM  
Baertram
 
Baertram's Avatar
AddOn Author - Click to view AddOns

Forum posts: 2708
File comments: 3230
Uploads: 57
Oh, found 1 error in my post.
LAM global variable LibAddonMenu2 was added with lam version 28, not 29
Report comment to moderator  
Reply With Quote
Unread 03/05/20, 11:11 AM  
Keldor
 
Keldor's Avatar
AddOn Author - Click to view AddOns

Forum posts: 58
File comments: 15
Uploads: 2
Hey Baertram,

thanks for the detailed info I'll update the txt file and the description. Thank you very much!

Originally Posted by Baertram
Hey Keldor,

thanks for the addon.
I guess this is no problem as most users updated their addons and libs already but if there is someone out there only using outdated other addon together with yours it could get buggy:

Your txt file says
Code:
## DependsOn: LibCustomMenu LibAddonMenu-2.0
But in your code you only use local LAM = LibAdonMenu2
This global variable was added with version 29 of LAM first.
So if any one uses an older version of LAM only it will fail to load the settings menu, allthough your addons depends on the lib properly (only the version was not added).

Either you need to add a hybrid call to LAM using first the global var and than a LibStub approach like this:
Lua Code:
  1. local LAM = LibAddonMenu2
  2. if not LAM and LibStub then LAM = LibStub("LibAddonMenu-2.0") end

But as LibStub is obsolete it's even easier:
Change your txt file to depend on LibAddonMenu-2.0>=29 so it only works with an updated version of the lib. Even better for new addons to make them dependend on the newest version of a lib available to force the users to update

Code:
## DependsOn: LibCustomMenu>=682 LibAddonMenu-2.0>=30
__________________
ESO-Database.com | Character- and Guild Database [EN/DE] (System Status)
ESO-Skillfactory.com | ESO Build planer [EN/DE/FR]
ESO-LFG.com | The ESO Looking for Group Tool [EN/DE/FR]
Report comment to moderator  
Reply With Quote
Unread 03/05/20, 10:56 AM  
Baertram
 
Baertram's Avatar
AddOn Author - Click to view AddOns

Forum posts: 2708
File comments: 3230
Uploads: 57
Hey Keldor,

thanks for the addon.
I guess this is no problem as most users updated their addons and libs already but if there is someone out there only using outdated other addon together with yours it could get buggy:

Your txt file says
Code:
## DependsOn: LibCustomMenu LibAddonMenu-2.0
But in your code you only use local LAM = LibAdonMenu2
This global variable was added with version 28 of LAM first.
So if any one uses an older version of LAM only it will fail to load the settings menu, allthough your addons depends on the lib properly (only the version was not added).

Either you need to add a hybrid call to LAM using first the global var and than a LibStub approach like this:
Lua Code:
  1. local LAM = LibAddonMenu2
  2. if not LAM and LibStub then LAM = LibStub("LibAddonMenu-2.0") end

But as LibStub is obsolete it's even easier:
Change your txt file to depend on LibAddonMenu-2.0>=29 so it only works with an updated version of the lib. Even better for new addons to make them dependend on the newest version of a lib available to force the users to update

Code:
## DependsOn: LibCustomMenu>=682 LibAddonMenu-2.0>=30
Last edited by Baertram : 03/17/20 at 11:48 AM.
Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump:

Support AddOn Development!

You have just downloaded by the author . If you like this AddOn why not consider supporting the author? This author has set up a donation account. Donations ensure that authors can continue to develop useful tools for everyone.